I was looking for a way to override the default version of jQuery that is being used in WordPress 2.9x and I came across this article that explains how to do this.

It doesn’t say in the article where you place this function, but I figured that I’d slide it into the functions.php in my active theme and this did the trick.

Read the full article and get the code here Force WordPress to use the Latest Version of jQuery | bavotasan.com.